问题

我使用的是Laravel Vue设置,并在Laravel Elixir,Webpack和 laravel-elixir-vue-2 < / a>包.

我已经看过几个其他的SO问题,我知道这通常是一个问题,没有引用vue.js的独立版本

但是,laravel-elixir-vue-2软件包别名为独立版本,因此模板可以从.vue文件加载.仍然,我每次得到这个错误:

[Vue:Warn] vue 2.0 Failed to mount component: template or render function not defined. (found in component <top> at ../resources/assets/js/components/top.vue)

我可以看到vue.js是从vue / dist / vue.js?0598:2611在控制台中提取的.

任何人都能看到我遗漏的内容吗?

app.js

import Vue from 'vue'
import top from './components/top.vue'

new Vue({
el: '#app',
components: { top }
})

//I've also tried this: 

// new Vue({
//  components: {
//    top
//  },
// render: h => h(top),
// }).$mount('#app')

top.vue

<template>
   <div class="top">
     <p>hi</p>
   </div>
</template>
<script>
 export default {};
</script>

index.blade.php

<div>
   <div id="app">
<top></top>
   </div>
</div>
{!! HTML::script('js/app.js') !!}

package.json

{
  "private": true,
  "scripts": {
  "prod": "gulp --production",
  "dev": "gulp watch"
},
"devDependencies": {
   "bootstrap-sass": "^3.3.0",
   "gulp": "^3.9.1",
   "laravel-elixir": "^6.0.0-9",
  "laravel-elixir-vue-2": "^0.2.0",
  "laravel-elixir-webpack-official": "^1.0.2"
  }
 }

gulp.js

var elixir = require('laravel-elixir');
elixir.config.sourcemaps = true;
require('laravel-elixir-vue-2');

elixir(function(mix) {
  mix.webpack('app.js', 'public/assets/js');
});

编辑:更新

更改gulp.js语法修复了我的错误.

var elixir = require('laravel-elixir')
require('laravel-elixir-vue-2')

elixir(mix => {

  mix.webpack('app.js');

  mix.styles([
    "normalize.css",
    "main.css"
    ]);

});

编辑:我添加了导出默认{};到模板脚本



解决方法

像我在问题中的评论,我有同样的问题. 在我的情况下,我有两个酏剂电话,像这样:

elixir(mix => {
    mix.browserSync({
        proxy: 'example.dev',
        open: false
    });
});

elixir(mix => {
    mix.sass('app.scss');
    mix.webpack('app.js');
});

我不知道为什么,但两个酏剂电话是打破webpack. 我把我的gulpfile改成:

elixir(mix => {
    mix.sass('app.scss');
    mix.webpack('app.js');
    mix.browserSync({
        proxy: 'example.dev',
        open: false
    });
});

@retrograde,thx为您的评论提示:)

编辑: 请参阅此 Laravel Elixir问题




相关问题推荐